View Ticket
Ticket UUID: d581f0338c55b7ca40e13f4c2e29e75d01482433
Title: please delete this ticket.
Status: Closed Type: Build Problem
Severity: Minor Priority: Low
Subsystem: Resolution: Rejected
Last Modified: 2019-11-07 16:24:09
Version Found In: 1.6.7
User Comments:
avl42 added on 2019-11-07 16:15:28:
Building tls1.6.7 on a Solaris 11.2 machine(yes, old) with developerstudio12.5 compiler gives warnings:

"tls.c", line 1528: warning: argument #4 is incompatible with prototype:
        prototype: pointer to const unsigned char : "/usr/include/openssl/x509.h", line 1021
        argument : pointer to char
(and 6 more copies of that warning for lines 1529 to 1534)

This ticket is mostly for documenting purposes.
On Solaris 11.3 with same compiler version no warnings show up.

avl42 added on 2019-11-07 16:18:32:
Sorry, I mixed up the machines... it's the 11.3 where the warnings show up, not the 11.2